MOVEMENT SALE! Get discounts on gear used by artists at Movement 2016. Ends 5/30 at 11:59pm.
Due to the Holliday there will be no phone support until 5/31.

MF3D DeckGratMotion

Description and Instructions

Please note: the v2 Mapping requires your MF3D firmware to be updated to at least 30 May 2013.

Video for v1 Mapping versions: https://www.youtube.com/watch?v=rPqISfKs5no

Note (for v1 versions): If you have updated to the latest MF3D firmware (30 May 2013) you will need to load the Legacy->Standard firmware for this mapping to work as expected. 
This can be found in the Tools->Alternate Firmware section of the MF Utility


Setup Steps

1. In order to use this mapping, please download and unzip the mapping files. Inside you should see a .tsi file, a .mfs file, and a .png layout file.

2. Open the MF Utility and Import the .mfs file. This will import the proper MF3D settings and button colors. Be sure to press Send to Midi Fighter. You are welcome to change the button colors to what you want in the MF Utility. Please note that the mapping will override the set colors in some cases (but never for the downpress colors so feel free to change those as you like).

3. In Traktor's Preferences window, press the large Import button on the bottom left. Note: If buttons/modes are not loading the proper effects (such as the Beatmasher for the Mash buttons or Delay for Echo Freeze button) please repeat this step and import the FX settings one more time.

4. Go into the Controller Manager and make sure that the In-Port and Out-Port for the mapping are set to your MF3D for both (2) parts of the mapping.

5. Start 3D Jamming!
Mf3d_deckgratmotion_v2_layout
Problem downloading or other issues? Let us know on the forum.
-
Comments for v2.0.0
Icondiscoball
Chris Francis about 1 month ago
The mapping is definitely not working with the latest version of traktor. No gater, beatmasher buttons are coming in as delay, no echo. Shame, loved this mapping and used it loads on my sets.
Dj_ff
flashflooder about 1 month ago

just tested this mapping on an mf3d for the first time in months. still works just fine for me on traktor 2.10. there might be something wrong with how the mf3d was set up or the fx settings didn't import correctly (sometimes it takes two imports if your exsiting settings are significantly different)

Sketchy 6 months ago
My Echo delay is coming is as beatmasher, how do I change this?
Dj_ff
flashflooder about 1 month ago

usually that is just from the fx not importing in the correct order. generally a re-import of the mapping with the large import button (to over-write all the settings and not just the mappings which includes fx settings) should do the trick

Dj_ff
flashflooder 6 months ago
I've heard from some people recently that they've had issues with this mapping. The only mentioned issues so far have to do with the LED visual response of various modes specifically, the motionFX preset buttons and the Flux mode flashing. If any one is experiencing these issues or others comment on this post so when I have a chance I can try to test and work through them all. Thanks and sorry for the delays. I don't do much mapping anymore.
1
ABraSSive 2 months ago

Everything works fine on Deck A but when I switch to Deck B, C, and D I have no effects or anything.

Dj_ff
flashflooder about 1 month ago

usually that means the MF3D is in the wrong mode. it should be in 4 Banks Disabled Hold mode if I remember correctly and not in 4 Banks mode which causes the MIDI to shift on each page (when it's all mapped to the first page and just uses modifiers with the top buttons)

Iconcd
Stuart 7 months ago
This isn't working with the new Trakor 2.10.0 software. Deleted and repeated the installation and still no luck. Had to revert to 2.7. Is there an update at all?
Dj_ff
flashflooder 6 months ago

Hi Stuart, no update at the moment but I will have some time in the next week or two to try to create one. I haven't touched this mapping in a while so I don't exactly know what's wrong yet.

Iconcd
Stuart 6 months ago

Thanks Dude thought i was going mad! Still the best map!

Dj_ff
flashflooder 6 months ago

I'm testing this mapping right now with Traktor 2.10.0 and not seeing any major problems. What isn't working for you?

Iconmixer
T 10 months ago
This new mapping is sweet! I have a few things not working after watching the video. I am on win7 64bit running traktor 2.6.3. I also have a VCI-400SE. I used the big import button for the Vestax and used the small import for the MF3D. For the VCI-400SE I used for the sound, and fixed the ports in and out for both Vestax genaric and addon. The MF3D I place Both part of motion and focus for in and out ports to MF3D. I am useing FW 30 May 2013 and the MF3D DeckGratMotion v2.mfs for the MFutilty. I have re imported all my mappings too before testing and posting Now getting all that out of the way. Parts that are not matching up are the Lights and Side buttons. Sync button does not Blink when flex mode is on. When holding any of the side buttons, it will not Blink on witch one is selected. Forward, left, right, none will show what settings its on. (the setting however is accepted and working correctly after pushing a button) The Cue is the same way Kinda. It lights up or does not. Depending if active. Does not have the low light and bright light like the video. The loop cue seems to be have a different color as well. If I hit the button right side. It seems to go in a lock up mode. Only way to get it back is hitting the same button. Not sure The loop and cue area lights does not seem to match up like video ether. Love all the DJTT gear that I own. flashflooder makes some sick mappings for all my gear.
Dj_ff
flashflooder 6 months ago

Hmm this sounds like an issue yikes. I'm wondering if maybe the default firmware on the MF got updated to change the led style. Or I suppose midi out in traktor could have changed. to be honest i haven't looked at this mapping in a while but since so many ppl are having issues i'll try to soon. Sorry for the delay.

Dj_ff
flashflooder 6 months ago

Testing the mapping now for the firs time in a while. I can confirm the Flex mode not blinking issue (although for me it will blink if Sync is on and thus already a Red color). However, the side buttons motionFX preset LED functionality is all working totally fine for me. I'm testing it on Traktor 2.10.0 but designed this on a way older version of Traktor so I'm not really sure what's going on. Any other info you can share?